Windows Mobile デバイスセンターが起動しない

【症状】

Windows10でWindows Mobile デバイスセンター(ver. 6.1)が起動しなくなっていた。
CanonのハンディであるPrea GT30の検針プログラムを修正しなくちゃいけないのだが、困ったことだ;;
2017/05時点では問題なく使えていたのに・・・?

調べてみると,
「Windows Mobile 2003 ベース デバイスの接続」というサービスが起動できていない。
イベントには「CreateSemaphore(0x80070005) エラーのため、Windows Mobile 2003 ベース デバイスの接続サービスを起動できませんでした (エラー コード情報を参照してください)。」とエラーが記録されていた。

ネットで調べてみると、Windows10 Creator Updateが当たるとこうような症状になるみたいだ。


(追記:2018/01/28)
その後のUPDATEでも同様の現象が発生した。UPDATEのたびにこの作業をしないといけないかも;;


【解決方法】

「Windows Mobile 2003 ベース デバイスの接続」サービスの

  • 「ログオンユーザ」を「ローカルシステム アカウント」
  • 「デスクトップとの対話をサービスに許可」を「チェックあり」

にすればよい。

 

これでPreaGT30の開発がやっとできるようになった。あせったなぁ。

ちなみに、以下のサービスも起動させとかないといけないので、うまくいかない時は確認してみてね。

  • Remote Procedure Call (RPC)
  • Remote Procedure Call (RPC) Locator < ---※自動起動になってないかも

Follow me!

Windows Mobile デバイスセンターが起動しない” に対して11件のコメントがあります。

  1. 匿名 より:

    上記自己レスです。再インストールしたら解決しましたorz

  2. 匿名 より:

    参考にさせて頂いておりましたが、Win10 1903ではサービスそのものが無くなってしまいました(泣)

  3. 匿名 より:

    ありがとうございます。
    助かりました!

  4. 匿名 より:

    この記事のおかげで助かりました。
    私はWindows Mobile 2003 ベース デバイスの接続に加えて、
    Windows Mobile ベース デバイスの接続も同様に設定することで解決しました。

  5. 匿名 より:

    ありがとうございました。
    この記事で助かりました。

  6. shintaro より:

    コメントありがとうございます。
    この記事、なんか役立ってますね。
    うれしいです。

  7. 匿名 より:

    同現象で困っていましたが、解決することができました。
    ありがとうございました。

  8. 匿名 より:

    認識しなくて困っていたところでした。
    大変助かりました。

  9. 匿名 より:

    デバイスセンター立ち上がりました
    助かりました

  10. - より:

    同様の状況でしたが、解決しました。
    ありがとうございます。

  11. odataiki より:

    役に立ちました!
    ありがとうございます!

コメントを残す

メールアドレスが公開されることはありません。